АРМ Оператора

Отчет предназаначен для работы с заявками и отгрузками на указанную дату для 1С Предприятие 7.7 Комплексная

В отчете отображается основная информация, необходимая для работы оператора:

  • — Остатки товаров на складе
  • — Количество заказанного товара
  • — Количество отгруженного товара
  • — Количество зарезервированного товара

Детализация по

  • заказам
  • отгрузкам
  • резервам

Добавлены возможности

  • округления товара до коробки
  • выборочное исправление количества товара в накладной

Алгоритм работы:
1. Проводим все заказы покупателей на выбранную дату
2. Формируем отчет АРМ Оператора
3. Исправляем количество (убираем красноту)
4. Проводим все накладные
5. Групповая печать документов

Ускоряемся с помощью прямых запросов 1С++

1
2
3
4
5
6
7
    Регистр.Заявки.ДоговорПокупателя = Договор;
    Регистр.Заявки.ЗаявкаПокупателя  = ТекущийДокумент();
    // ресурсы
    Регистр.Заявки.КоличествоРасход = ТаблицаДокумента.Количество;
    Регистр.Заявки.СтоимостьРасход    = ТаблицаДокумента.Сумма;
    // выполняем движение
    Регистр.Заявки.ДвижениеПриходВыполнить();
  1. Добавить строки в Модуль документа РеализацияТоваров
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
//добавить в ПроведениеПоРегистрам()
Процедура ДвижениеЗаявокПокупателяПростое()
    Если ПустоеЗначение(ДокОснование)=0 Тогда 
        Если ДокОснование.Вид()="ЗаявкаПокупателя" Тогда 
            ВыбратьСтроки();
            Пока ПолучитьСтроку()=1 Цикл
                Регистр.Заявки.Фирма = Фирма;
                Регистр.Заявки.Номенклатура = Номенклатура;         
                Регистр.Заявки.ДоговорПокупателя = Договор;
                Регистр.Заявки.ЗаявкаПокупателя = ДокОснование;
                Регистр.Заявки.КоличествоРасход = Количество;
                Регистр.Заявки.СтоимостьРасход = Сумма;
                Регистр.Заявки.ДвижениеРасходВыполнить();
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
Изменения затрагивают стандартные механизмы формирования проводок документов 1С Предприятия. Поэтому, желательно, чтобы изменения вносил программист 1С.

Благодарности: Людям, создавшим и поддерживающим проект 1С++

Cкачать отчет на Infostart’е.